RedSky E911 Anywhere and Horizon Mobility Voice Gateway TLS Certificate Rotation

Scheduled for Nov 25, 19:00 - 22:00 CST

Update

The previous notice went out as "Wednesday" the correct day is Tuesday, November 25, 2025
Posted Nov 14, 2025 - 15:51 CST

Scheduled

On Tuesday, November 25, 2025, RedSky will be performing TLS certificate rotation on our voice gateways between 7:00 PM and 10:00 PM (CST).

Please ensure that your systems trust the latest Sectigo Public Root and Intermediate CA certificates if sending SIP TLS traffic. It is also recommended to have redundant connectivity configured to another RedSky voice gateway during this maintenance window. During this period, call routing will continue to be processed through alternate RedSky gateways, ensuring that calls are directed to the appropriate Public Safety Answering Point (PSAP) without interruption.

More information and certificate links can be found here:
https://www.sectigo.com/knowledge-base/detail/Sectigo-new-Public-Roots-and-Issuing-CAs-Hierarchy/kA0Uj0000004IrB
Posted Nov 14, 2025 - 14:23 CST
This scheduled maintenance affects: E911 Anywhere (Call Routing), Horizon Mobility for Webex Calling (Call Routing), and Horizon Mobility for Service Providers (Call Routing).