Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 27, 2026 - 21:00 CST
Update
Please be aware that RedSky will be updating E911Anywhere call routing components to address an issue that causes some emergency calls to be routed to relay center unnecessarily.
This update is scheduled to begin at 9pm CT on 1/27/2026.
No interruptions to portal access, API, or call routing services are expected.
Posted Jan 27, 2026 - 21:00 CST
Scheduled
Please be aware that RedSky will be updating E911Anywhere and Horizon Mobility call routing components to address an issue that causes some emergency calls to be routed to relay center unnecessarily.
This update is scheduled to begin at 9pm CT on 1/27/2026.
No interruptions to portal access, API, or call routing services are expected.
Posted Jan 26, 2026 - 15:45 CST
This scheduled maintenance affected: E911 Anywhere (Call Routing).